Search found 88 matches

by gavin.ridley.utk
Mon Mar 27, 2017 10:22 pm
Forum: Bugs, problems, questions & feeback
Topic: [reprocessing] Issue with type 2 flows
Replies: 21
Views: 53081

Re: [reprocessing] Issue with type 2 flows

So this one is indeed intended to be fractional units as well, right? I'll browse through makeburnmatrixmsr.c and try my best to figure things out!
by gavin.ridley.utk
Mon Mar 27, 2017 7:27 pm
Forum: Bugs, problems, questions & feeback
Topic: [reprocessing] Issue with type 2 flows
Replies: 21
Views: 53081

Re: [reprocessing] Issue with type 2 flows

I really think that Serpent is using a flow MUCH lower than expected though. Here is my calculation of the fractional flow that you pass in to Serpent, and it matches the above input file. So, let's just say you want to dump out the fuel tank over 50 days, and fully replace it with the refill materi...
by gavin.ridley.utk
Sat Mar 25, 2017 11:14 pm
Forum: Bugs, problems, questions & feeback
Topic: [reprocessing] Issue with type 2 flows
Replies: 21
Views: 53081

Re: [reprocessing] Issue with type 2 flows

Here's a new, vastly simplified example that encounters the same issue: just starting your fast cylinder off with some ~17% enriched fuel, then slowly dumping it over 50 days and reloading with 100% fuel. Doing the run even at zero power, you will see that keff does not rise. Starting the core on 10...
by gavin.ridley.utk
Fri Mar 24, 2017 7:40 pm
Forum: Bugs, problems, questions & feeback
Topic: [reprocessing] Issue with type 2 flows
Replies: 21
Views: 53081

Re: [reprocessing] Issue with type 2 flows

Yes, numbers in the mass flows are reasonable. This should equate to a net volumetric flow of 20 ccm/s through the core.

I just tried with "set bumode 1" and the results appear completely identical.
by gavin.ridley.utk
Fri Mar 24, 2017 4:48 am
Forum: Bugs, problems, questions & feeback
Topic: [reprocessing] Issue with type 2 flows
Replies: 21
Views: 53081

Re: [reprocessing] Issue with type 2 flows

This is indeed the exact input causing trouble. You see, even if the densities of Umetal and refuel are falling, the refuel and Umetal don't seem to make it into the fuel. Notice that here, I am adding a huge amount of 20% enriched fuel into an LEU mix, so you can expect reactivity to rise a good bi...
by gavin.ridley.utk
Thu Mar 23, 2017 1:41 am
Forum: Bugs, problems, questions & feeback
Topic: [reprocessing] Issue with type 2 flows
Replies: 21
Views: 53081

[reprocessing] Issue with type 2 flows

Hi all, In this post we found that some nonphysical effects can happen as a consequence of using type 0 flows. Recently, I have been attempting to modify my molten salt reactor refueling code to utilize exclusively type 2 rather than type 0 flows. It just so happens that I have confirmed nonphysical...
by gavin.ridley.utk
Mon Mar 20, 2017 10:25 pm
Forum: Bugs, problems, questions & feeback
Topic: [reprocessing] large atom density rise in CRAM
Replies: 13
Views: 43600

Re: [reprocessing] large atom density rise in CRAM

Update on this thread:

I have some evidence that type 2 flows actually aren't working correctly either for cases like this. New post documenting it coming!
by gavin.ridley.utk
Mon Feb 27, 2017 11:21 pm
Forum: Input
Topic: If I give keff power iteration mode a source, is it used?
Replies: 1
Views: 4930

If I give keff power iteration mode a source, is it used?

Hey Serpent users, Let's say that I generate a fission source using "set csw myfiss.dat". Now, I'd like to start a new input file off of that source neutron distribution. If I use the typical "set pop ..." alongside a source definition that points to the old output, like: src mysource sf "myfiss.dat...
by gavin.ridley.utk
Mon Feb 27, 2017 5:44 pm
Forum: Bugs, problems, questions & feeback
Topic: SERPENT 2.1.28 Problem with reprocessing
Replies: 4
Views: 9944

Re: SERPENT 2.1.28 Problem with reprocessing

This seems to happen to me when I use TMP or TMS on materials alongside reprocessing.
by gavin.ridley.utk
Tue Feb 21, 2017 10:51 pm
Forum: Bugs, problems, questions & feeback
Topic: Missing power output in type 2 multiphysics
Replies: 1
Views: 9323

Missing power output in type 2 multiphysics

Hi all, I am trying to test out the multiphysics interface with a very simple geometry: a plutonium disk in water. I treat the disk as a pin, and am hoping to get radial power output. It seems that my power output file is blank, however. Main input file: set title "chunk of Pu in water" % surfaces s...