Page 1 of 2

xsdirconvert.pl issues

Posted: Mon Jul 22, 2013 8:47 pm
by eugene171
I am attempting to change the xsdir files (sss_endfb7u.xsdir, and the other xsdir files in xsdata) into xsdata files using xsdirconvert.pl.

I have obtained the newest copy of xsdirconvert.pl from http://montecarlo.vtt.fi/links.htm
I am running this off of a dual-boot windows 7 / ubuntu device; this is being run on Ubuntu.

I have a copy of the dsxirconvert.pl file in the folder that the xsdir file i intend to convert. when I type the command into the terminal as follows:

~/xsdata/jeff31$ xsdirconvert.pl sss_jeff31.xsdir > sss_jeff31.xsdata

I get the response

xsdirconvert.pl: command not found

When I use

~/xsdata/jeff31$ perl xsdirconvert.pl sss_jeff31.xsdir > sss_jeff31.xsdata

No response is given by the terminal, it just goes to the state of ~/xsdata/jeff31$ BUT it makes a blank (openable, no text inside) version of sss_jeff31.xsdata in the appropriate folder.

How do i proceed?

Re: xsdirconvert.pl issues

Posted: Tue Jul 23, 2013 3:49 am
by Jaakko Leppänen
You might be missing the executable flag in the file. Try chmod u+x xsdirconvert.pl, and the run the script from command line.

Re: xsdirconvert.pl issues

Posted: Wed Jul 24, 2013 3:51 am
by eugene171
That fixed it, thanks!

xsdirconvert.pl issues

Posted: Fri Feb 07, 2014 5:41 am
by Mohamed Salah
Hi Jaakko,
Hi all
In my current point of my project , I would like to design a full core CANDU reactor with both MCNP6 and serpent
The two model are very similar in everything
But when I include the thermal scattering table of S(a,B) of UO2
mt1 o2/u.17t u/o2.17t $oxygen in UO2 and U238 in UO2

the difference is ~3mk MCNP(1.09050 std“0.00045”) and serpent (1.08778 std”0.00125”)
but if I remove this mt1 o2/u.17t u/o2.17t $oxygen in UO2 and U238 in UO2 .
from MCNP code the MCNP result of criticality becomes (1.09663 std“0.00045”)
So, how can I define thermal scattering of O/U table in SERPENT , if it included I didn’t find it? or I should remove this line from my MCNP code to make it real comparison

Is this difference is acceptable ?! I was very precise about the thermal scattering of moderator and coolant and materials temperatures too

I tried to make this conversion xsdir of MCNP6.1
What I did ?
1- Copy the MCNP_Data Folder to the xsdata ( the same folder of other serpent data)
2- Copy the updated xsdirconvert.pl inside the same folder and inside the endf71SaB folder too
3- I used “../….$chmod u+x sxdirconvert.pl endf71SaB>>sss_endf71SaB
4- And, xsdir_mcnp6.1>>sss_endfb7.1.data
5- The data file inside the endf71SaB were zipped I unzip one of them and try to convert it but it gave me empty file !
6- And I used different other options usually I have obtained an empty file with same name!
does anyone know how it can work ?

Re: xsdirconvert.pl issues

Posted: Fri Feb 07, 2014 10:31 am
by Jaakko Leppänen
The xsdirconvert.pl script is applied to the directory file. So if you have MCNP xsdir file called "xsdir_mcnp6.1", the correct command line operation is:

Code: Select all

./xsdirconvert.pl xsdir_mcnp6.1 > xsdir_serpent
If the data paths in xsdir_mcnp6.1 are set correctly, you shoud get a directory file you use in the main input:

Code: Select all

set acelib "xsdir_serpent" "second_xsdir_file" ...
You should then be able to use the S(a,b) libraries similar to those provided with the installation package. No modifications are needed for the actual data libraries.

Re: xsdirconvert.pl issues

Posted: Sat Feb 08, 2014 1:13 am
by Mohamed Salah
Hi Jaakko

thanks, I had tried this
"hussein@hussein-HP-Z800-Workstation:~/c757mnyws00/xsdata/MCNP_DATA$ xsdirconvert.pl xsdir_mcnp6.1>xsdir_serpent"
but it gave me
"bash: /home/hussein/c757mnyws00/util/xsdirconvert.pl: Permission denied"

I changed the ownership using "-v chown" of the folder "util" and the file xsdirconvert.pl but no change happened

although I am already copied the "xsdirconvert.pl" in to the MCNP_DATA directory the only thing happened is creating an empty file named of "xsdir_serpent"

also I tried to use the flagged "chmod u+x sxdirconvert.pl"

thanks

Re: xsdirconvert.pl issues

Posted: Sat Feb 08, 2014 1:31 am
by Jaakko Leppänen
The error message suggests that you have no permissions to execute xsdirconvert.pl. Try: "chmod u+rx /home/hussein/c757mnyws00/util/xsdirconvert.pl"

Re: xsdirconvert.pl issues

Posted: Thu Feb 13, 2014 10:57 pm
by Mohamed Salah
Hi Jaakoo
1) regarding data conversion
unfortunately,
it doesn't work I did all the probable choices

it gave me nothing (empty folder)

look at my screen shoot in the attached. this was the last part of my trying
what did I do ? I copied the unzipped MCNP_DATA inside the xsdata of serpent as shown in fig 2
2)
my another question

I am doing full core calculation of CANDU reactor so
there is a difference in keff (MCNP)=1.09294 (0.00014) and the keff(Serpent)=1.08809 (.00042) when 3000 X3000 history run with 100 inactive
the difference in the flux is about 2.85%
which is a bit out of the statistical error

I knew from your validation, the Serpent and MCNP keff results should be inside the statistical error for the cell calculation

so are these results for full core calculation is resalable ?

thanks

Re: xsdirconvert.pl issues

Posted: Fri Feb 14, 2014 4:31 am
by Mohamed Salah
Hi Jaakko ,
I re-define the path of the xsdir_mcnp6.1 . It runs but it doesn't find ***ACE file in /xdata/file name does not exist
i think the problem now is the MCNP6 data files are Not ACE compression format
i tried to convert it from ZIP file to ACE file i didn't sucess yet
so please if any one heve the same problem

mainly I would like to redefien the S(A,B) thermal scattring data to use it in the Serpent
mt1 o2/u.17t u/o2.17t $oxygen in UO2 and U238 in UO2
may target is UO2 thermal scattring data this makes 6mk diffrence in my model reactor .



thanks
Mohamed

Re: xsdirconvert.pl issues

Posted: Tue Jan 12, 2016 11:43 am
by Andy_Turner
I have similar issues.
When I run
perl xsdirconvert.pl xsdir_mcnp6.1 >> xsdir.serp

It complains for each nuclide
"96242.70c: ACE file "/xdata/endf70k" does not exist."
(for example).
The '/' that is prefixing the string is not correct. Certainly '/xdata/..' does not exist - it is 'xdata/..' i.e. below the current directory.
The leading '/' is not in the source xsdir file of course.