Page 1 of 1

Compiling Serpent 2.1.31: error

Posted: Sat May 25, 2019 1:07 am
by mascovale
Dear all,

I am having an issue compiling the most recent release of Serpent (2.1.31). I get the following error:

Code: Select all

gcc -O3 -ffast-math -Wall -ansi -Wunused -DOPEN_MP -fopenmp -pedantic -c collectfet.c
collectfet.c: In function ‘CollectFET’:
collectfet.c:60: error: expected ‘#pragma omp’ clause before ‘collapse
I was wondering whether you have encountered this before or if this is an issue with my compiler. Thanks in advance for the feedback.

Re: Compiling Serpent 2.1.31: error

Posted: Mon May 27, 2019 8:30 am
by Ville Valtavirta
Hi,

at least gcc 7.4.0 compiles it with no trouble.

-Ville

Re: Compiling Serpent 2.1.31: error

Posted: Mon May 27, 2019 9:48 am
by Riku Tuominen
Check this question at Stack Overflow https://stackoverflow.com/questions/588 ... ma-omp-for

Re: Compiling Serpent 2.1.31: error

Posted: Mon May 27, 2019 11:08 pm
by mascovale
Hi Riku and Ville,

thanks for your help. As I feared, the compiler on our cluster is too old.

Thanks
Valerio