Compiling LibGD

Compiler issues (Intel compiler, mpicc, etc.), data libraries and everything needed to get Serpent running is discussed here
Post Reply
winsor
Posts: 1
Joined: Sat Sep 24, 2011 11:05 pm

Compiling LibGD

Post by winsor » Sun Sep 25, 2011 12:55 am

A search tells me there are no mentions of LibGD on this website, so let me start at the beginning. I am a very new user of Serpent. I have run the vver example in both 1.1.7 (from RSICC) and 1.1.16, compiled without graphics. The Serpent Installation manual tells the user to get the GD Graphics Library from http://www.libgd.org/ but that website reports (as of today, 24 September 2011):
Site is sadly not available. We are working to restore the wiki and the downloads as soon as possible. The wiki will be available through bitbucket.org's wiki. Bugs can and should be reported at our bitbucket's project page:
https://bitbucket.org/pierrejoye/gd-libgd Thanks for your understanding,
If you go to that website and click "Issues," you will find that there are 5 going back to May 2011, none of which are closed.

If you click the Download tab, at the bottom, you will find a "default" commit. I tried compiling it.

My skills in C extend to "./configure; make" and not very much beyond that. My host OS is openSuSE Linux 11.4. All compilation tools were obtained from that distribution.

The documentation is deficient. Specifically:
  • The documentation includes an INSTALL file, which tells the user to "./configure" and then "make install." However, the required configure and Makefile files are not present.
  • There is a README.TXT file. It says the same thing as INSTALL. Incorrect.
  • There are configure.ac and Makefile.am files. A web search suggests that Automake and Autoconf tools can process these files. I have tried both. The results are in the attached files. They fail.
  • There is a README.CMAKE file. It gives specific instructions on how to do the CMake in a subfolder. The results are also in the attached folder. It also fails.
  • At this point, I have exhausted all obvious options.
Help, please!

P.S.: I have tried adding a file with extension .txt .asc and no extension at all. What is allowed?

User avatar
Tuomas Viitanen
Posts: 65
Joined: Thu Mar 25, 2010 1:50 pm
Security question 2: 0
Location: VTT Technical Research Centre of Finland, Espoo

Re: Compiling LibGD

Post by Tuomas Viitanen » Wed Sep 28, 2011 10:16 am

Hello,

Disclaimer: I don't understand very much of Linux operating systems or differences between different Linux distributions, so this might not work for you.

I installed LibGD on my Ubuntu 10.14 (Lucid Lynx) using the Synaptic package manager available in Ubuntu Linux. If openSUSE has such a manager, I quess that would be the easiest way of installing the LibGD. The correct package is probably named libgd2, libgd2-xpm, libgd2-dev or something similar.

I quess writing

Code: Select all

sudo apt-get install libgd2 
in the terminal should do basically the same trick if your distro does not include a graphical package manager utility.

Hope this helps!

Tuomas

nelsonag
Posts: 8
Joined: Mon Sep 19, 2011 5:35 pm

Re: Compiling LibGD

Post by nelsonag » Wed Oct 26, 2011 12:12 am

I just found the GD library in OpenSUSE: http://software.opensuse.org/search?q=g ... debug=true
(If that whole link did not work, go to software.opensuse.org and search for GD).

That site shows you the exact package name to look for in the Yast Software Management (Or Zypper if using the command line). I am not familiar with the commands for either of those systems, so I recommend just using Yast's GUI and searching for GD (or typing in the whole package name from the above website).

Adam

alain_hebert
Posts: 4
Joined: Thu Feb 14, 2013 5:25 pm
Security question 1: No
Security question 2: 92

Re: Compiling LibGD

Post by alain_hebert » Thu Feb 14, 2013 5:32 pm

I found the following procedure for installing libGD on MacOSX. I believe it can be useful...

Download and install libgd using this link: http://www.boutell.com/gd/http/gd-2.0.33.tar.gz

macuser:~/Downloads$ cd gd-2.0.33
macuser:~/Downloads/gd-2.0.33$ ./configure
macuser:~/Downloads/gd-2.0.33$ make
macuser:~/Downloads/gd-2.0.33$ sudo make install

ghrays
Posts: 1
Joined: Mon Oct 21, 2013 2:06 am
Security question 1: No
Security question 2: 92

Re: Compiling LibGD

Post by ghrays » Fri Nov 22, 2013 7:39 pm

I'm using Ubuntu and this seemed to work for me:

sudo apt-get install libgd2-xpm-dev

Shadi Ghrayeb

ddwooten
Posts: 7
Joined: Sun Jun 08, 2014 3:54 pm
Security question 1: No
Security question 2: 92

Re: Compiling LibGD

Post by ddwooten » Sun Jun 08, 2014 3:59 pm

I can confirm that to resolve the SERPENT compilation error of "fatal error: gd.h: No such file or directory", at least on my system running Ubuntu 12.04 LTS, issuing the following command and moving through the prompts

" sudo apt-get install libgd2-xpm-dev "

will allow you to compile without the above error appearing.

david.colameco
Posts: 1
Joined: Tue Feb 09, 2016 9:42 pm
Security question 1: No
Security question 2: 92

Re: Compiling LibGD

Post by david.colameco » Sun Mar 20, 2016 5:03 am

For openSUSE 42.1 I used "zypper install gd-devel" which is basically equivalent to Shadi's suggestion. This resolved the compilation error also.

Dave

Post Reply